Inhalt

Cisco DHCP Range pro VLAN

Inhalt

Um auf einem Cisco einen DHCP Server einzurichten braucht es nicht viel. Um in verschiedene VLANs mit IP-Adressen zu versorgen muss man nur die VLAN Interfaces mit den richtigen IP-Adressen konfigurieren.

Switch(config)# ip dhcp pool DHCP-Vlan1
Switch(dhcp-config)# network 172.16.100.1 /24
Switch(dhcp-config)# domain-name example.com
Switch(dhcp-config)# dns-server 172.16.0.10 172.16.0.11
Switch(dhcp-config)# default-router 172.16.100.254
Switch(dhcp-config)# lease 7
Switch(dhcp-config)# exit
Switch(config)# ip dhcp pool DHCP-Vlan2
Switch(dhcp-config)# network 172.16.200.1 /24
Switch(dhcp-config)# domain-name example.com
Switch(dhcp-config)# dns-server 172.16.0.10 172.16.0.11
Switch(dhcp-config)# default-router 172.16.200.254
Switch(dhcp-config)# lease 7
Switch(dhcp-config)# exit
Switch(config)# interface vlan1
Switch(config-if)# ip address 172.16.100.1 255.255.255.0
Switch(config)# interface vlan2
Switch(config-if)# ip address 172.16.200.1 255.255.255.0
Switch(config-if)# end
Switch# show ip dhcp binding

Plain and simple